Odpowiedz
Autor Wiadomość
Nie podano
PostWysłany: 09 Gru 2012, 10:33 
Awatar użytkownika
Dołączenie:
Listopad 2008
Posty: 260
nick w SL: Anka Sporg
hej

Problem dotyczy głownie shoutboxa. Czasami w ogóle mi się nie ładuje. Niekiedy z wielominutowym opóźnieniem. Zaobserwowałam, że to zjawisko występuje tylko wtedy , kiedy nie otwiera się reklama na samej górze (pod paskiem "Strona głowna, Forum, Panel użytkownika.... Szukaj"). Np. dziś, reklama sie nie chce wczytać (mam w jej miejsce puste okno) a co za tym idzie shoutbox też się nie ładuje.

Czy nie dałoby się uniezależnić od siebie te dwie funkcje ?
Czy można by ewentualnie sprawić, żeby shoutbox zamiast czekać najpierw na wczytanie reklamy, inicjował się wcześniej?

pozdrawiam


Profil E-mail Offline
Nie podano
PostWysłany: 09 Gru 2012, 13:52 
Awatar użytkownika
Dołączenie:
Styczeń 2011
Posty: 339
nick w SL: Konstancja Shoreland
Tez czasem mi zajmuje chwile (pare sekund)
zaladowanie shout boxa , ale nie widze zwiazku z reklama.
Moze chodzi o szybkosc internetu ?


Profil E-mail Offline
Nie podano
PostWysłany: 09 Gru 2012, 14:15 
Awatar użytkownika
Dołączenie:
Listopad 2008
Posty: 260
nick w SL: Anka Sporg
hej

Internet mam 10 mbit wiec to raczej nie to.
Parę sekund to nie parę minut wiec nie zwracasz na to uwagi.
U mnie wygląda tak, że jak shoutbox się nie otwiera, przewijam na początek strony. Nie ma reklamy. Czasami się reklamy nie doczekam, przewijam na dół i w oknie shoutboksa widzę tekst na czerwono o błędzie. Nie pamiętam dokładnej treści. Jak zobaczę następnym razem to wkleję. Jeżeli zaś reklama wskoczy, to po przewinięciu a dół widzę co ludzie shoutboksie piszą.
Także związek między reklamą a shout boksem istnieje :). Domniemywam, że w kodzie forum jest tak zrobione, ze okno z reklama jest przed shoutboxem , dlatego jest inicjowane wcześniej. Reklama się nie wczytuje i skrypt czeka i czeka. Jak się nie doczeka to wywali błędem na wszystkim co jest poniżej. Tak ja to postrzegam.

pozdrawiam


Profil E-mail Offline
Nie podano
PostWysłany: 09 Gru 2012, 15:16 
Awatar użytkownika
Dołączenie:
Marzec 2009
Posty: 703
nick w SL: Adamus Inglewood
Powiązanie jest prozaiczne, zarówno Shoutbox jak i widżet reklamy napisane są w javascript. Twój błąd prawdopodobnie oznacza, ze masz problem u siebie w systemie z wirtualną maszyną Javy. Powinno pomóc uaktualnienie Javy które dostaniesz TUTAJ
:)


Profil E-mail Offline
Nie podano
PostWysłany: 09 Gru 2012, 15:50 
Dołączenie:
Lipiec 2008
Posty: 3307
nick w SL: MaxJames Chemistry
Ja czasami po prostu przerywam wczytywanie strony i się shoutbox wyświetla, ale rzadko tak się dzieje. Chociaż bywają reklamy, które potrafią cały system przymulić.


Profil E-mail Offline
Nie podano
PostWysłany: 09 Gru 2012, 16:23 
Awatar użytkownika
Dołączenie:
Listopad 2008
Posty: 260
nick w SL: Anka Sporg
Hej

No dobrze, ale skoro mam (teoretycznie) coś nie tak z javą, to raczej powinno być cały czas tak samo. A to raz jest dobrze raz jest źle. Np rano było źle, teraz jest dobrze. Poza tym Linux (bo na tym systemie jestem) sam sobie uaktualnia jave i wszystko inne co ma w sobie zainstalowane.

pozdrawiam


Profil E-mail Offline
Nie podano
PostWysłany: 09 Gru 2012, 16:44 
Awatar użytkownika
Dołączenie:
Marzec 2009
Posty: 703
nick w SL: Adamus Inglewood
Przyznaję, że na Linuxie się nie znam. Jeśli jednak problem występuje u Ciebie a u innych nie - co widać po osobach stale korzystających ze shouta, przypuszczam, że błąd występuje u Ciebie. Sprawdziłbym jednak wersję tej Javy (na stronie którą podałem jest aplet do tego), ewentualnie sprawdziłbym czy na innej przeglądarce wygląda to podobnie. Inna sprawa, że źle napisany aplet naprawdę potrafi wywalić stronę, a nawet cały serwer ;). Tu jednak nigdy mi się to nie przytrafiło, żeby było aż tak źle.


Profil E-mail Offline
Nie podano
PostWysłany: 09 Gru 2012, 21:30 
Awatar użytkownika
Dołączenie:
Listopad 2010
Posty: 52
nick w SL: Natascha Iwish
Więc na stronie jest AJAX Chat - i jak się kliknie w linka do niego to można wyczytać że:
Cytuj:
AJAX Chat is a free and fully customizable open source web chat implemented in JavaScript, PHP and MySQL (...)
a JavaScript to nie Java,,,


Profil E-mail Offline
Nie podano
PostWysłany: 10 Gru 2012, 09:14 
Awatar użytkownika
Dołączenie:
Czerwiec 2011
Posty: 107
nick w SL: Syntia Sahara
U mnie jak sie tak robi wystarczy odświeżenie stronki i wchodzi wszystko :)


Profil E-mail Offline
Nie podano
PostWysłany: 10 Gru 2012, 09:43 
Awatar użytkownika
Dołączenie:
Listopad 2008
Posty: 260
nick w SL: Anka Sporg
Hej

Dzisiaj ponowiła się sytuacja. Czekałam ze dwie minuty aż się pojawi shoutbox. Tym razem zaobserwowałam coś jeszcze. Cały czas firefox na dole pisał: "Łączenie z planetcalypso.eu...".
Czyli moja teoria spiskowa dotycząca powiązania reklamy z chatboxem nabiera sensu :) .
Forum cały czas czekało na podesłanie widżeta (czy jak to się zwie) przez te planetcalypso.eu. Dopiero jak dostało to co chciało, kontynuowało dalej.

Synthia, u mnie odświeżanie stronki nie pomaga...

pozdrawiam

Edit:

Znowu nie działa. Ponownie zacięło się na "Łączenie z planetcalipso.eu...". tym razem shoutbox się nie załadował i napisał następujący błąd: "(12.38) Chatbot: Błąd: Stan Połączenia:0".

I co admin na to ? :>.


Profil E-mail Offline
Nie podano
PostWysłany: 11 Gru 2012, 19:57 
Moderator
Awatar użytkownika
Dołączenie:
Grudzień 2008
Posty: 3210
nick w SL: Nemesis Igaly
Krewetka, spróbuj innej przeglądarki. Być może zablokowałaś sobie coś z związanego z Shoutboxem w jakimś antyreklamowym pluginie. Soutbox czasem się dziwnie zachowuje, tak z zasady. Nie wymaga też Javy, działa nawet na przeglądarkach mobilnych ;)


Profil E-mail Offline
Nie podano
PostWysłany: 12 Gru 2012, 00:02 
Dołączenie:
Lipiec 2010
Posty: 171
nick w SL: Hyde McAuley
Po prostu soutbox w phpbb wczytuje sie na samym końcu, dopiero kiedy wczytaja sie reklamy. Jeśli obrazek reklamy jest pobierany z innego serwera (reklamodawcy), to niestety może sie tak dziać w przypadku kiedy ten serwer jest bardzo obciążony. jedyne wyjście to zablokować tę reklamę w przeglądarce.

PS. prawdopodobnie chodzi tu o reklame flash playera, która tak długo się ładuje

PS. admin powinien se wleść do swojego adwordsa w gogole i wywalić te reklame, bo faktycznie prze nią shout sie nie ładuje

Cytuj:
Jeśli jednak problem występuje u Ciebie a u innych nie - co widać po osobach stale korzystających ze shouta, przypuszczam, że błąd występuje u Ciebie.


Ten błąd występuje pod postacią braku adblocka u koleżanki hehe


Profil E-mail Offline
Nie podano
PostWysłany: 12 Gru 2012, 08:27 
Awatar użytkownika
Dołączenie:
Listopad 2010
Posty: 52
nick w SL: Natascha Iwish
Adblock nie jest sprawce zamieszania, no chyba ze właśnie ktoś coś przypadkiem lub nieumiejętnie sobie zablokował,,,


Profil E-mail Offline
Nie podano
PostWysłany: 12 Gru 2012, 11:11 
Dołączenie:
Lipiec 2010
Posty: 171
nick w SL: Hyde McAuley
Nie mówię że jest. Adblock jest raczej lekarstwem ;)


Profil E-mail Offline
Nie podano
PostWysłany: 18 Gru 2012, 11:16 
Awatar użytkownika
Dołączenie:
Listopad 2008
Posty: 260
nick w SL: Anka Sporg
Hej

Chyba wadliwa reklama została usunięta. Od kilku dni forum działa idealnie.
Dziękuję.

pozdrawiam


Profil E-mail Offline

Wyświetl posty z poprzednich:  Sortuj według  

Odpowiedz



Kto jest na forum

Użytkownicy przeglądający to forum: Brak zarejestrowanych użytkowników oraz 3 gości

Panel
Góra
Skocz do:  
SecondLife.pl designed by CvX! Powered by phpBB © phpBB Group - tłumaczenie
SecondLife.pl nie jest oficjalną stroną Second Life. SecondLife.pl is an unofficial Second Life website. SecondLife, SL logo and Second Life related graphics are trademarks of Linden Lab.

Entropia Universe , Planet Calypso